From 22699bc913eec26881e180852413553de2ac493b Mon Sep 17 00:00:00 2001
From: Thomas Glanzmann <thomas@glanzmann.de>
Date: Sat, 11 Mar 2023 19:02:46 +0100
Subject: [PATCH] disable freedreno to be able to compile mesa and add because
 it is used in pkgbuild -Dandroid-libbacktrace=disabled

---
 mesa-debian/rules | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/mesa-debian/rules b/mesa-debian/rules
index c925492..52f49d6 100755
--- a/mesa-debian/rules
+++ b/mesa-debian/rules
@@ -78,14 +78,14 @@ else
 	GALLIUM_DRIVERS += nouveau virgl
 
 	# Freedreno requires arm in addition
-	ifneq (,$(filter arm arm64,$(DEB_HOST_ARCH_CPU)))
-		GALLIUM_DRIVERS += freedreno
-	endif
+	# ifneq (,$(filter arm arm64,$(DEB_HOST_ARCH_CPU)))
+	# 	GALLIUM_DRIVERS += freedreno
+	# endif
 
 	# etnaviv, tegra, vc4 and v3d kernel support are only available on armhf and arm64
 	ifneq (,$(filter $(DEB_HOST_ARCH), armhf arm64))
 		GALLIUM_DRIVERS += etnaviv panfrost svga tegra vc4 v3d
-		VULKAN_DRIVERS += broadcom freedreno
+		VULKAN_DRIVERS += broadcom
 	endif
 
 	ifneq (,$(filter $(DEB_HOST_ARCH), armhf arm64 riscv64))
@@ -105,7 +105,7 @@ else
 	EGL_PLATFORMS += ,wayland
 
 	ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel powerpc ppc64 ppc64el s390x))
-		confflags_VALGRIND += -Dvalgrind=enabled
+		confflags_VALGRIND += -Dvalgrind=enabled -Dandroid-libbacktrace=disabled
 	endif
 
 	# WSL supports only amd64 and arm64
-- 
2.39.5