ISE 11.1 notes
authorMichael Gernoth <michael@gernoth.net>
Sun, 31 May 2009 16:22:41 +0000 (18:22 +0200)
committerMichael Gernoth <michael@gernoth.net>
Sun, 31 May 2009 16:22:41 +0000 (18:22 +0200)
index.html

index d005e9bb205eb7f861c54788880c3c05ab3b8d08..4a4369ce73eeafb20d69372fb5a4037d96236571 100644 (file)
                The library is called <i>libusb-driver</i> as it was developed to support the USB cable, but later
                extended to also support parallel cables.
                </P>
-               <P><B>News</B> (<I>2008-03-26</I>): Xilinx has released their own drivers based on libusb with ISE Design Suite 10.1.
-               To use them, you need to set the environment-variable <kbd>XIL_IMPACT_USE_LIBUSB</kbd> to <kbd>1</kbd>
-               before running the tools. The driver on this page no longer needs to be preloaded if you only used
-               it to access USB cables. Parallel port support still seems to rely on <i>windrvr</i>, which can be
-               emulated by <i>libusb-driver</i>.</P>
-               <P><B>Using 32-bit ISE 10.1 on a 64-bit platform:</B> When using the 32-bit JTAG tools from ISE Design
-               Suite 10.1 on a 64-bit machine, the tools will not connect to the cable but output the following
-               error: <I>Cable operation is not supported when running the 32-bit version of the application on a
-               64-bit platform.</I>
-               To fix this, run the tools with <KBD>linux32</KBD> or preload the newest 32-bit version of
-               <i>libusb-driver</i>. This will lead the tools to believe that they are running on a 32-bit
-               platform and allows them to connect to the cable.
+               <P><B>News</B>
+               <UL>
+                       <LI><I>2008-03-26</I>: Xilinx has released their own drivers based on libusb with ISE Design Suite 10.1.
+                       To use them, you need to set the environment-variable <kbd>XIL_IMPACT_USE_LIBUSB</kbd> to <kbd>1</kbd>
+                       before running the tools. The driver on this page no longer needs to be preloaded if you only used
+                       it to access USB cables. Parallel port support still seems to rely on <i>windrvr</i>, which can be
+                       emulated by <i>libusb-driver</i>.</P>
+                       <P><B>Using 32-bit ISE 10.1 on a 64-bit platform:</B> When using the 32-bit JTAG tools from ISE Design
+                       Suite 10.1 on a 64-bit machine, the tools will not connect to the cable but output the following
+                       error: <I>Cable operation is not supported when running the 32-bit version of the application on a
+                       64-bit platform.</I>
+                       To fix this, run the tools with <KBD>linux32</KBD> or preload the newest 32-bit version of
+                       <i>libusb-driver</i>. This will lead the tools to believe that they are running on a 32-bit
+                       platform and allows them to connect to the cable.</LI>
+
+                       <LI><I>2009-05-31</I>: ISE Design Suite 11.1 now uses their libusb based drivers as default, without
+                       the need to set <kbd>XIL_IMPACT_USE_LIBUSB</kbd>. If you want to use this driver with ISE 11.1 for USB
+                       cables and disable the builtin support for libusb, you now have to set <kbd>XIL_IMPACT_USE_LIBUSB</kbd>
+                       to <kbd>0</kbd> (<kbd>export XIL_IMPACT_USE_LIBUSB=0</kbd> or <kbd>setenv XIL_IMPACT_USE_LIBUSB 0</kbd>).
+                       For parallel cables Xilinx still relies on <i>windrvr</i>. This library works fine with parallel cables and
+                       ISE 11.1 with no need for <i>windrvr</i>.</LI>
+               </UL>
                </P>
                <H2>Supported Cables</H2>
                The following cables are reported to work with this driver:
@@ -67,6 +77,7 @@
                <H2>Supported Software</H2>
                The following software is reported to work with this driver:
                <ul>
+                       <li><a href="http://www.xilinx.com/ise/logic_design_prod/webpack.htm">ISE Webpack 11.1</a></li>
                        <li><a href="http://www.xilinx.com/ise/logic_design_prod/webpack.htm">ISE Webpack 10.1</a></li>
                        <li><a href="http://www.xilinx.com/ise/logic_design_prod/webpack.htm">ISE Webpack 9.2 SP1, SP2, SP3 and SP4</a></li>
                        <li><a href="http://www.xilinx.com/ise/logic_design_prod/webpack.htm">ISE Webpack 9.1 SP1, SP2 and SP3</a></li>
Impressum, Datenschutz